opengnsys-1.1.1 (#16) - Problema instalación agente en Ubuntu 20.04 y consulta (#463) - Message List

Problema instalación agente en Ubuntu 20.04 y consulta
 unsolved

Hola,

Estoy intentando instalar el agente en una Ubuntu 20.04 y me da el siguiente error de dependencias que no logro solucionar:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'ogagent' instead of './ogagent_1.1.1b_all.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 ogagent : Depends: python-qt4 (>= 4.9) but it is not installable
           Depends: python-requests (>= 0.8.2) but it is not installable
           Depends: python-prctl (>= 1.1.1) but it is not installable
           Depends: python-distro but it is not installable
E: Unable to correct problems, you have held broken packages.

Alguna idea?

Por otra parte, necesitaría saber donde se almacena en el servidor el estado de los clientes (ogLive, ocupado, Linux, Windows, etc).

SAlu2 y gracias

  • Message #1004

    Hola,

    También he probado con la versión 1.1.2 del agente y me da el mismo error.

    SAlu2

    • Message #1007

      En la version de ubuntu que indicas ya no esta instalado por defecto python2 esta python3 debes instalar manualmente

      sudo apt install python2

      En caso de no localizarte el paquete activa los repositorios universales

      sudo add-apt-repository universe sudo apt update sudo apt install python2

      Luego esta el problema para las librerias qt que sigo viendo como instalarlas

      sudo add-apt-repository ppa:rock-core/qt4 sudo apt-get update sudo apt update sudo apt install libqt4-declarative libqt4* libqtcore4 libqtgui4 libqtwebkit4 qt4*

      En este punto me quedado yo, pero vamos que si me da muchos dolores de cabeza migro a Ubuntu 18.04.5 LTS (Bionic Beaver) que para lo que van hacer los alumnos lo mismo les da

      • Message #1008

        Muchas gracias por la respuesta, lo probaré...

        Yo en mi caso, si no me funciona tendré que renunciar al agente, ya que el profesor ha pedido tener esa versión de Ubuntu en concreto.

        SAlu2

        • Message #1009

          si encuentras las solución no dudes en postearla por favor yo hare lo mismo

Attachments

No attachments created.