source: ogAgent-Git/linux/ogagent-template.spec

qndtest
Last change on this file was 6c2d948, checked in by Ramón M. Gómez <ramongomez@…>, 4 years ago

#959: Update OGAgent version and changelog.

  • Property mode set to 100644
File size: 2.2 KB
Line 
1%define _topdir %(echo $PWD)/rpm
2%define name ogagent
3%define version 0.0.0
4%define release 1
5%define buildroot %{_topdir}/%{name}-%{version}-%{release}-root
6
7BuildRoot: %{buildroot} 
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Summary: OpenGnsys Agent for Operating Systems
12License: BSD3
13Group: Admin
14Requires: chkconfig initscripts python-six python-requests python-distro PyQt4 libXScrnSaver
15Vendor: OpenGnsys Project
16URL: https://opengnsys.es/
17Provides: ogagent
18
19%define _rpmdir ../
20%define _rpmfilename %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm
21
22
23%install
24curdir=`pwd`
25cd ../..
26make DESTDIR=$RPM_BUILD_ROOT DISTRO=rh install-ogagent
27cd $curdir
28
29%clean
30rm -rf $RPM_BUILD_ROOT
31curdir=`pwd`
32cd ../..
33make DESTDIR=$RPM_BUILD_ROOT DISTRO=rh clean
34cd $curdir
35
36
37%post
38systemctl enable ogagent.service > /dev/null 2>&1
39
40%preun
41systemctl disable ogagent.service > /dev/null 2>&1
42systemctl stop ogagent.service > /dev/null 2>&1
43
44%postun
45# $1 == 0 on uninstall, == 1 on upgrade for preun and postun (just a reminder for me... :) )
46if [ $1 -eq 0 ]; then
47    rm -rf /etc/ogagent
48    rm /var/log/ogagent.log
49fi
50# And, posibly, the .pyc leaved behind on /usr/share/OGAgent
51rm -rf /usr/share/OGAgent > /dev/null 2>&1
52
53%description
54This package provides the required components to allow this machine to work on an environment managed by OpenGnsys.
55
56%files
57%defattr(-,root,root)
58/etc/ogagent
59/etc/xdg/autostart/OGAgentTool.desktop
60/etc/init.d/ogagent
61/usr/bin/OGAgentTool-startup
62/usr/bin/ogagent
63/usr/bin/OGAgentTool
64/usr/share/OGAgent/*
65/usr/share/autostart/OGAgentTool.desktop
66
67%changelog
68* Fri Feb 07 2020 Ramón M. Gómez <ramongomez@us.es> - 1.1.1b-1
69- Use python-distro to detect the distribution version
70
71* Thu May 23 2019 Ramón M. Gómez <ramongomez@us.es> - 1.1.1-1
72- Set connection timeout
73- Compatibility with "Exam Mode" from the University of Seville
74
75* Wed May 22 2019 Ramón M. Gómez <ramongomez@us.es> - 1.1.0a-1
76- Fix a bug when activating the agent with some network devices
77
78* Tue Oct 13 2016 Ramón M. Gómez <ramongomez@us.es> - 1.1.0-1
79- Functional OpenGnsys Agent interacting with OpenGnsys Server 1.1.0
80
81* Tue Jul 18 2015 Adolfo Gómez García <agomez@virtualcable.es> - 1.0.0-1
82- Initial release for OpenGnsys Agent
83
Note: See TracBrowser for help on using the repository browser.